System Software Requirements.

Many folks are not reading the System Requirements and falling foul when they wanted to buy the FS9 version but ended up with the FSX version and vice versa or it will not run on there Operating Systems.

These are here for a reason and the onus is on the customer 'You' to check the product page carefully and to ensure that the product you want does indeed suit your operating system or version of Flight Simulator.

Please do not assume that something that may work in FS9 will work in FSX as this is not necessarily the case or any other product we sell.  

If in doubt ask here at the forums or write to support@aerosoft.de

Refunds will not be given if you purchase something that is not suitable for your system or version of Flight Simulator or any other software product purchased,.

Have more questions? Submit a request

Comments

Powered by Zendesk